1397/05/28 21:51 مشکل متون فارسی در design view برای فایل های xaml
arash_121

 
با سلام
آپدیت جدید ویژوال استادیو (15.8.1) نصب کردم
یه مشکلی برای متون فارسی وجود داره. کلا متون فارسی تو بخش طراحی درست نشون داده نمیشه

لطفا برای حل مشکل راهنمایی بفرمائید.
1397/05/28 23:31
حاجی شریفی
مؤسس سایت
 
سلام
این مورد برایم پیش نیامده و بعید میدانم بتوانم کمک تان کنم ...

در کمال ناامیدی سه پیشنهاد دارم:
= = = = = = = = = = = = = =
اول) مطمئن شوید که فایل axml جاری تان با کدینگ UTF8-65001 یا UTF16-1200 ذخیره شده باشد.
(البته این فایل xml است و توسط VS با کدینگ UTF8 ساخته میشود ولی بازبینی کردنش ضرر ندارد!)
برای این کار به نمای source فایل بروید (غیر design یا همان سمت راست تصویری که آپلود کرده اید) از از منوی File فرمان Save As بدهید.
در فرمی که برای ذخیره باز میشود کنار دکمه Save فلش کوچکی وجود دارد، از آنجا Save with Encoding را انتخاب کنید.

در دیالوگی که باز میشود گذینه UTF8-65001 یا UTF16-1200 را انتخاب کنید (بطور معمول در بالای فهرست قرار دارند)

در صورت تغییر به UTF16 خط اول axml را هم اصلاح کنید.
البته خودم الان انجام دادم و بعد از یکبار بازکردن designer ، مجدد به UTF8 اصلاح شد.
ولی احتمال بسیار ضعیفی وجود دارد که اگر گیری وجود داشته باشد، با این کار refresh شود.


دوم) به قول دوستان یک بار پیاده شوید و سوار شوید!
برنامه Visual Studio را بسته و خارج شوید.
به محل پروژه خودتان بروید و دستی پوشه های obj و bin را کامل حذف کنید.


سوم) اگر برنامه تان روی 'گوشی واقعی' صحیح اجرا میشود که مهم آن است کار کند!
تا نصب بعدی ویندوز و VS و... تحمل اش کنید!!!

گمان نمیکنم کمک زیادی کرده باشم.
موفق باشید.
1397/05/28 23:44
arash_121

 
خیلی ممنون از پاسختان.
پس این مشکل فقط برای من است و برای شما در این ورژن چنین مشکلی وجود ندارد؟
چون این مشکل کلا برای هر پروژه ای که برای زامارین اندروید ایجاد میکنم. هست.
1397/05/28 23:50
حاجی شریفی
مؤسس سایت
 
نقل قول نوشته شده توسط: arash_121
برای شما در این ورژن چنین مشکلی وجود ندارد؟

چند کار دستم است که عقب افتاده و باید تکمیل کنم و فرصت کمی دارم ...
درواقع ، دارم اعتراف می کنم که فرصت بروزرسانی را پیدا نکرده ام !

ولی طبق تجربه ، گمان نمیکنم هرکس بروزرسانی کند ، دچار این مشکل شود.
برخی از مشکلات این تیپی فقط روی یک رایانه و در شرایط خاص رخ میدهد.
1397/06/02 20:15
حاجی شریفی
مؤسس سایت
 
سلام
به نسخه 15.8.1 بروزرسانی کردم و این مشکل در رایانه من هم رخ داد !
مورد را به developer community گزارش دادم.
پیشنهاد میکنم ، درصورتیکه دوستان با این مشکل روبرو هستند، به مطلب مربوطه در سایت رای دهند تا حل آن در اولویت قرار گیرد.
لازم بذکر است که screenshot ارسال شده ، ولی فقط برای تیم پشتیبانی مایکروسافت قابل رویت است.

لینک مشکل:
https://developercommunity.visualstudio.com/content/problem/320664/arabicpersianpashto-language-problem-in-the-axml-d.html